Tag: cloud

Problema entre módulo de AWS EKS y Terraform 14

Hice el upgrade a la versión 14 de Terraform y me encontré con un problema a la hora de intentar levantar un cluster en EKS de AWS, el error es el siguiente:

Error: Unsupported Terraform Core version
on .terraform/modules/vpc/versions.tf line 2, in terraform:
2: required_version = ">= 0.12.7, > 0.14"

Revisando el código encontré el culpable

module "vpc" {
   source  = "terraform-aws-modules/vpc/aws"
   version = "2.47.0"

...
}

La versión del módulo de AWS no era compatible con Terraform 14, asi que me puse a buscar una nueva versión que la soportará y resultó ser la versión 2.58 https://github.com/terraform-aws-modules/terraform-aws-vpc/releases/tag/v2.58.0

Y con eso el problema fué resuelto, espero les sirva 🙂